Vesta

Vesta Panel PHP Selector Kurulumu

VestaCP, açık kaynak kodlu, ücretsiz olarak sunulan Linux hosting kontrol panellerinden bir tanesidir. Stabil çalışması ve sade arayüzü ile linux hosting kullanıcıları tarafından da oldukça tercih ediliyor. Geliştiricileri de sürekli yeni geliştirmeler yapıyor.

PHP selector yani php versiyon seçici de bunlar bir tanesi.

PHP Selector Nedir?

PHP selector, her domain için farklı bir PHP versiyonu seçmenizi sağlar. Sunucuda birden fazla PHP versiyonu yer alıyorsa, dilediğiniz domainlerde farklı php versiyonları çalıştırabilirsiniz.

Vesta Panel PHP Selector Kurulumu

Öncelikle Vesta Panel kurulu sunucunuza “root” kullanıcı ile oturum açın ve aşağıdaki işlemleri uygulayın;

cd /usr/local/src
wget http://mirror.skamasle.com/vestacp/PHP/sk-phpinstaller_beta02_3.sh

Ardından dosyayı çalıştırın. Bu işlem tüm PHP versiyonlarını sisteminize kuracaktır.

bash sk-phpinstaller_beta02_3.sh all

Eğer spesifik olarak versiyonları kurmak isterseniz, aşağıdaki şekilde kurabilirsiniz;

Önemli; Eğer versiyonları tek tek kuracaksanız, ilk çalıştırdığınız kurulumun varsayılan (default) versiyon olacağını bilmelisiniz. Bu sebeple ilk kurulumu 7.0 veya üzerinde yapmanızı tavsiye ederiz. Şayet kuruluma PHP 5.4 ile başlarsanız varsayılan versiyon 5.4 olacak ve phpmyadmin gibi yazılımlar çalışmayacaktır.

bash sk-phpinstaller_beta02_3.sh php54
bash sk-phpinstaller_beta02_3.sh php55
bash sk-phpinstaller_beta02_3.sh php56
bash sk-phpinstaller_beta02_3.sh php70
bash sk-phpinstaller_beta02_3.sh php71
bash sk-phpinstaller_beta02_3.sh php72
bash sk-phpinstaller_beta02_3.sh php73
bash sk-phpinstaller_beta02_3.sh php74

Kurulumu yaptıktan sonra, Vesta Panel üzerinden PHP versiyonlarını değiştirebilirsiniz.

Yazar Hakkında

admin

8 Yorum

Yorumu buraya yazabilirsiniz

admin için bir cevap yazın Cancel reply

  • Php7.3 ile sunucum var.
    Rehbere ulaştıktan sonra PHP seçici çalışıyor, ancak sunucu için varsayılan PHP şimdi 5.4 ve phpMyAdmin çalışmıyor:
    Currently installed version is: 5.4.45
    PHP 5.5+ is required.

  • Vesta güzel bir panel. Özellikle mail işlemleri için gayet kullanışlı. PHP seçici olmadığı için vazgeçmeyi düşünüyordum ki yazınıza denk geldim.