Freebsd

Freebsd 64bit için 32bit kütüphaneleri desteği

Freebsd 8 ve önceki sürümlerden önce, sysinstall diyerek 32bit desteği verebiliyorduk. Fakat 8 sonrası zaten sysintall kalktığından bu desteği farklı şekilde verebiliyoruz.  Bir 32bit uygulama çalıştırıyorsanız muhtemel alacağınız hata “ELF interpreter /libexec/ld-elf.so.d not found, error 8” şeklinde olacak. 8 ve öncesi ise yapacağınız işlem şu şekilde;

sysinstall

Configure->Distributions

lib32 compatibility

deyip, işlemlere onay vermek.

Fakat 8 sonrası ise aşağıdaki adımları takip etmeniz gerekecek.

fetch ftp://ftp.freebsd.org/pub/FreeBSD/releases/amd64/10.1-RELEASE/lib32.txz (Bu 10.1 sürümü için, farklı bir sürüm ise, ftp adresinden dosyayı bulabilirsiniz.

tar -xvpJf lib32.txz -C /

İşlem bu kadar.

Eğer hata devam ederse, /usr/ports/mics/compat8x, 9x ve 11x’i make install deyip kurmayı deneyebilirsiniz.

Manually install lib32 libraries on a FreeBSD amd64

Let’s say you forget to add support for 32 bit libraries when you’ve installed FreeBSD amd64 version. To install those
libraries later just fetch the archive containing 32 bit libraries and untar/unzip it:
fetch ftp://ftp.freebsd.org/pub/FreeBSD/releases/amd64/10.1-RELEASE/lib32.txz
tar -xvpJf lib32.txz -C /
And voila you’ll have your 32 bit libraries installed on FreeBSD amd64